Author Topic: Problems connecting the khepera IV to a wifi network.  (Read 233 times)

D.Ali

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Problems connecting the khepera IV to a wifi network.
« on: March 13, 2019, 01:27:04 PM »
Hi,
I am having issues activating the wifi of the robot. I followed the instruction in the Khepera IV User Manual 4.0, section 9.2.1.
First, I have opened the file in /etc/wpa_supplicant/wpa_supplicant-wlan0.conf and i found the file already configured with a wireless network named korebot without encryption. So i didn't change it.
After that i have configured the interface file in /etc/network/interfaces as following:

auto wlan0
#iface wlan0 inect dhcp
iface wlan0 inet static
           wireless_mode managed
           wireless_essid korebot
           address 172.16.156.57
           netmask 255.255.255.0
           gateway 172.16.156.1

the address being the static robot ip i found in the robot (i didn't change it either)
the gateway is the ip address i have used for my pc.

for the wifi network i configured ad-hoc network with the name korebot with the Network Manager of Ubuntu 14.04.

finally i have rebooted the robot and the pc.

However, after all that, the robot was not connected, and if I use the command ping i get the message that the address is unreachable.

Please advice. Thank you.

kteam

  • Administrator
  • Hero Member
  • *****
  • Posts: 378
  • Karma: +7/-1
Re: Problems connecting the khepera IV to a wifi network.
« Reply #1 on: March 25, 2019, 07:53:19 AM »
Hi,

you have to adapt the ESSID name and IP address to your network. This file is edited as an example with a Wifi called Korebot.
For example, if your Wifi is named "HomeWifi", you have to change "korebot" to "HomeWifi" and change the IP address too (you have certainly a range of 192.168.1.1 to 192.168.1.1).

Best regards