Author Topic: Cannot connect Khepera IV to the wifi  (Read 4398 times)

Eric

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Cannot connect Khepera IV to the wifi
« on: September 05, 2019, 04:33:13 PM »
Hi,

I tried to follow the instructions to config the wifi, the manual says "Edit the file /etc/wpa_supplicant/wpa_supplicant-wlan0.conf to meet you need. ". However, I only find a file named "wpa_suppliant.conf", and I edit this file as follows:

1 #/etc/wpa_supplicant/wpa_supplicant.conf                                   
  2 #with WPA-PSK TKIT: 
  3 network={
  4         ssid="DragonRainbow"
  5                                                             
  6         scan_ssid=1
  7         psk="famousdesk146"                                                 
  8         key_mgmt=WPA-PSK
  9         group=TKIP
 10         pairwise=TKIP
 11         proto=WPA                                                           
 12         priority=1
 13
 14 }

The robot cannot connect to the wifi after editing this file. In the forum, I find that we should also edit the interface file in /etc/network/interfaces as follows:

 29 auto wlan0
 30 iface wlan0 inet static
 31         wireless_mode managed
 32         wireless_essid DragonRainbow
 33         address 192.168.1.60
 34         netmask 255.255.255.0
 35         gateway 192.168.1.1

After that, I reboot the robot, but it still cannot connect to the wifi. I am wondering whether I am using a manual (Khepera IV V4.0) whose version is not the same as the Khepera IV I am using.

Could anyone give some suggestion? Thanks in advance!