Author Topic: Can't upload new program and reinstall bootloader to Kilobot  (Read 6080 times)

pioneer

  • Guest
When I tried to upload my program inside the Kilobot, it continued flashing blue and couldn't finish uploading.

So I press "Stop" button in KilobotController.exe and interrupt the upload. And then the Kilobot doesn't move any more.

I tried to program "KilobotFirstFirmware.hex" to the Kilobot, but AVR studio doesn't recognize the Kilobot.

How can I solve this problem and reset Kilobot in its initial state?

kteam

  • Administrator
  • Hero Member
  • *****
  • Posts: 378
  • Karma: +7/-1
Re: Can't upload new program and reinstall bootloader to Kilobot
« Reply #1 on: August 13, 2012, 09:02:31 AM »
Hello,

have you correctly use the flat cable to connect the OHC to the Kilobot? Sense?
have you correctly set the jumper on the OHC?
have you correctly configure the type of microcontroller on AVR studio?

If all thes points are correct, please be sure that you make correctly the contact on the Kilobot, and verify that you do not make a short circuit on the motor during the programming.

Finally please try to charge the battery of the Kilobot. If the battery is too low, maybe this can cause your problem.

Best regards

frankie9

  • Jr. Member
  • **
  • Posts: 4
  • Karma: +0/-0
Re: Can't upload new program and reinstall bootloader to Kilobot
« Reply #2 on: March 26, 2013, 03:01:52 AM »
If I have made a short circuit on the motor during the programming, and the kilobots keep blinking yellow, what can I do to fix with this problem???!!!!

kteam

  • Administrator
  • Hero Member
  • *****
  • Posts: 378
  • Karma: +7/-1
Re: Can't upload new program and reinstall bootloader to Kilobot
« Reply #3 on: March 27, 2013, 08:07:24 AM »
Dear frankie9,

could you explain more how you "made a short circuit on the motor during the programming" ?

You can reprogram the robot. See Kilobot user's manual, chapter 4.2.4 for reprogramming it's bootloader,
then 4.3.1 for sending its new program.

Best regards,
K-TEAM