Recent Posts

Pages: [1] 2 3 4 5 6 ... 10
Kilobot / Re: Kilobot bootloader programming problem
« Last post by kteam on October 29, 2018, 08:13:47 AM »

you have to select the ATmega328P in the Main tab as device. Set the Programming mode to ISP mode at 125kHz.

Then try to read the signature of the Kilobot (ensure a good connexion with the pin before trying to read). If the message failled appears, unplug and replug the USB on OHC at each retry.

Do not forget to change the jumper on the OHC to firmware mode (otherwise you will flash the OHC itself). And verify that the OHC is correctly recognize as a Jungo AVRispMkII.

Best regards
Kilobot / Kilobot bootloader programming problem
« Last post by sgfabr on October 26, 2018, 12:57:13 PM »
I am following the procedure 4.2.4 on the Kilobot manual. AVR Studio connects to the device but on top of the window that pops up it states:
AVRISP mkII in ISP mode with No device selected
Also, the Flash category under the Program tab is greyed out, and so I cannot specify the inout hex file.

What am I doing wrong please?
Khepera IV / Re: Installing Robot Operating System (ROS) on khepera IV
« Last post by williamdwarke on August 30, 2018, 05:33:03 PM »
Any luck with this? I was investigating the same thing and came to the conclusion that it would be more pain than it’s worth. Instead I’m writing a TCP communication client node and using each khepera as a server running its own standalone C++ program.
Kilobot / Re: Kilobots not responding to OHC
« Last post by kteam on June 19, 2018, 08:14:23 AM »

if the Robot didn't respond even after an firmware install means that the IR calibration has been erased (during update) or is not more correct.
in Both case, the only solution is to send back the robot to K-team for calibration.

Best regards
Kilobot / Real Time coding of kilobots from eclipse and matlab
« Last post by pradyum2104 on May 31, 2018, 07:03:51 PM »
I want to use the real time data of Matlab variables in Eclipse and want to generate the hex file from eclipse so as to burn it to the kilobots. Is there a way to send real time data from Matlab variables to eclipse environment?  and also is there a possibility to code kilobots with hex files from eclipse instead of using the kilogui application?
Kilobot / Kilobots not responding to OHC
« Last post by Amaya on February 27, 2018, 03:55:04 PM »

I am actually working with Kilobots on Debian. I have followed the instructions here :
Some kilobots work perfectly, while others do not repond at all to the OHC (when I use the kiloGUI interface), even though I have correctly updated the firmware on these kilobots, and they are turned on (green light flashing).
Is there any explanation for this issue? What should I do?

Khepera IV / ssh connection- response too slow
« Last post by Firhanh on November 11, 2017, 02:31:16 AM »

I'm able to connect my PC to khepera IV via ssh connection, the problem is the connection response is too slow..
I've tried to ping khepera IV IP adress from my PC and the result is shown below

Firhan@Hz:~$ ping
PING ( 56(84) bytes of data.
From icmp_seq=14 Destination Host Unreachable
From icmp_seq=15 Destination Host Unreachable
64 bytes from icmp_seq=9 ttl=64 time=18131 ms
64 bytes from icmp_seq=13 ttl=64 time=8056 ms
64 bytes from icmp_seq=20 ttl=64 time=907 ms
64 bytes from icmp_seq=21 ttl=64 time=4929 ms
64 bytes from icmp_seq=22 ttl=64 time=3912 ms
64 bytes from icmp_seq=23 ttl=64 time=2888 ms
64 bytes from icmp_seq=24 ttl=64 time=1864 ms
64 bytes from icmp_seq=25 ttl=64 time=840 ms
The ping is too high

but when I tried to ping my PC from khepera IV the response is great
root@khepera4_1118:~$  ping                                           
PING ( 56(84) bytes of data.                               
64 bytes from icmp_seq=1 ttl=64 time=5.73 ms                         
64 bytes from icmp_seq=2 ttl=64 time=5.73 ms                         
64 bytes from icmp_seq=3 ttl=64 time=5.70 ms                         
64 bytes from icmp_seq=4 ttl=64 time=5.70 ms                         
64 bytes from icmp_seq=5 ttl=64 time=2.86 ms                         
64 bytes from icmp_seq=6 ttl=64 time=6.65 ms                         
64 bytes from icmp_seq=7 ttl=64 time=6.47 ms                         
64 bytes from icmp_seq=8 ttl=64 time=5.64 ms                         
--- ping statistics ---                                               
8 packets transmitted, 8 received, 0% packet loss, time 7015ms                 
rtt min/avg/max/mdev = 2.868/5.565/6.652/1.085 ms       

Have anyone face this problem before? any solution?
I need your advice,

Thank you

Khepera IV / Installing Robot Operating System (ROS) on khepera IV
« Last post by Firhanh on November 08, 2017, 08:37:07 AM »

I want to install ROS in Khepera IV to make it easier to communicate with my PC.
The problem is I don't know if ROS is compatible with Khepera IV or not.
Does anyone have experience in doing this? Is it possible to install ROS on Khepera IV?

I'm looking for advice..
Thank you.
Khepera IV / Peoblem with SSH
« Last post by DrIsrael on September 11, 2017, 02:46:57 PM »
I have problems to connect with SSH
It appears "write failed: broken pipe" as message
when I try ssh root@IP
However Ping process works fine.
Khepera III / Khepera III in morse simulator
« Last post by pedroosi on August 14, 2017, 11:44:45 AM »

I am a university student and I am working with khepera III robot.
I need to define this robot in the Morse simulator.
Has anyone already done this?
Is there any place where I can download the configuration for the morse simulator?

Thank you
Pages: [1] 2 3 4 5 6 ... 10